FreeBSD Install BASH Shell – Instalar shell como padrão do usuário no freebsd

in BASH Shell, FreeBSD, Package Management

I’d like to Bash shell under FreeBSD for bash programming. How do I install bash shell under FreeBSD UNIX operating system?

Bash is an sh-compatible command language interpreter that executes commands read from the standard input or from a file. csh / tcsh (C shell with file name completion and command line editing) is the default shell under FreeBSD. However, you can easily install and use bash as shell.
Install bash under FreeBSD

Login as root and type the following commands to install bash using FreeBSD ports:
# portsnap update extract
# cd /usr/ports/shells/bash
# make install clean

To install FreeBSD binary package, enter:
# pkg_add -r bash
How do I use bash under FreeBSD?

To use bash shell, enter:
# bash
OR
# /usr/local/bin/bash
How do I set bash as a default shell?

To set bash as default, shell enter:
# chsh -s /usr/local/bin/bash {username}
# chsh -s bash

Verify that bash is default shell for a user account called vivek, enter:
grep {username} /etc/passwd

OR

egrep –color ‘{username}|zsh’ /etc/passwd

OR
finger {username}

Deixe um comentário